Installing Fedora 13 on HP Envy 15

I recently installed Fedora 13 on a USB 3.0 equipped Envy 15 laptop with Core i7 processor. First the hardware specs:

  • Intel(R) Core(TM) i7-720QM Quad Core processor (1.6GHz, 6MB L3 Cache) with Turbo Boost up to 2.8 GHz
  • 4 GB RAM
  • ATI Mobility Radeon HD 5830 Graphics
  • NEC uPD720200 USB 3.0 controller
  • BIOS ver: F.28

I installed from an external USB 2.0 DVD-ROM drive. First problem I ran into was that the installer would start up fine from DVD but failed to find the DVD drive later. This stalled the installation until I decided to connect the external USB 2.0 dribve to the eSATA/USB 2.0 port. After that installer found the DVD drive just fine. This indicates the installer kernel is missing xhci driver. It may be possible to load the xhci driver manually but workaround of connecting to the USB 2.0 port was easier :) I did have trouble with installer finding the DVD drive even when it was connected to eSATA/USB 2.0 port unless I booted installer with "askmethod" parameter. I did not run enough tests to verify that I did not have another problem (like just a loose cable). In any case, if you connect the DVD drive to eSATA/USB 2.0 port and installer still fails to find the drive, just boot with "askmethod" parameter.

The second problem I ran into while installing was that touchpad buttons did not work which stalled installation. A USB 1.1/2.0 mouse plugged into one of the two USB 3.0 ports does not work either with installer. Mouse must be plugged into the USB 2.0 port. I had to use an external USB hub so I could plug both DVD drive and mouse into the single USB 2.0 port. Once I got past these two problems, installation went smoothly.

Once Fedora 13 was installed and I rebooted the laptop, there were a number of ACPI errors at boot up:

ACPI Error (psargs-0359): [\_PR_.CPU0._PPC] Namespace lookup failure, AE_NOT_FOUND
ACPI Error (psparse-0537): Method parse/execution failed [\CPUT] (Node ffff88013ba74180), AE_NOT_FOUND
ACPI Error (psparse-0537): Method parse/execution failed [\PSSC] (Node ffff88013ba741a0), AE_NOT_FOUND
ACPI Error (psparse-0537): Method parse/execution failed [\_SB_.PCI0.LPCB.EC0_._REG] (Node ffff88013ba69a80), AE_NOT_FOUND

After boot up, I found that no thermal zones were detected in /proc/acpi/thermal_zone

. CPU fan runs continuously, although not at high speed. I did not encounter any overheating issues. Most everything worked fine on the laptop after installation except for the issues noted below:

TurboBoost worked on CPU which I verified using the cpustat utility from Len Brown here and here.
Graphics worked fine with no issues and display resolution was set up correctly at 1920x1080. I could not enable desktop effects with default installaion as it kept complaining that 3D acceleration is not enabled. /var/log/Xorg.o.log shows radeon driver in use and messages from the radeon driver indicate that direct rendering and acceleration are disabled. A newer version of radeon driver might possibly enable acceleration. I did not attempt to install fglrx driver as it did not seem to be straightforward. I installed flash plugin using these instructions and 1080p videos played very smoothly from youtube.
HDMI output works at 1080p. There was significant overscan and the picture on TV did not show the top and bottom bars from Gnome desktop.
Text console
Text console was automatically set up at high resolution with no tweaking required
USB 3.0
USB 3.0 driver was loaded automatically and USB 3.0 ports worked well after installation. Write speed to a USB 3.0 Buffalo drive averaged 94 MB/s while read speed avaeraged 124 MB/s
Wifi works. WiFi/Bluetooth kill button does not work. Wifi and Bluetooth continue to stay on after the kill button is pressed and kill LED also does not turn on.
Audio works. Audio mutes with the Audio mute button and audio mute LED turns on and off correctly.

Touchpad works but mouse buttons embedded in touchpad do not work. Touchpad can not be turned off by double tapping the touchpad on/off button

Webcam works with cheese

Bluetooth works. I was able to send/receive files to/from a phone and I was also able to browse filesystem on the phone

Suspend and hibernate
Suspend and hibernate both fail with error logged in dmesg:
pm_op(): usb_dev_suspend+0x0/0x10 returns -2
PM: Device usb2 failed to suspend: error -2

This looks like a bug in xhci driver.
Special keys
Audio mute, volume up and down keys work. Brightness control keys work. Calculator key launches a calculator and mail key launches evolution. Web browser key launches a file browser. Remaining two special keys on the left side do not do anything

All in all Fedora 13 is usable on Envy 13 when used with an external mouse since touchpad buttons do not work. Lack of suspend and hibernate support can be a significant nuisance.