hpacucli configure P410

We are expiriencing problems in configuring of cacheratio param on HP
Smart Array P410. Battery installed. Lates firmware installed.
We are using hpacucli (hpacucli_8.35-7.0.3-5_amd64.deb) on Ubuntu 9.10

=> ctrl all show detail

Smart Array P410 in Slot 4
Bus Interface: PCI
Slot: 4
Serial Number: PACCR9SYN3PL
Cache Serial Number: PACCQ9SY952F
RAID 6 (ADG) Status: Disabled
Controller Status: OK
Chassis Slot:
Hardware Revision: Rev C
Firmware Version: 3.30
Rebuild Priority: Medium
Expand Priority: Medium
Surface Scan Delay: 15 secs
Queue Depth: Automatic
Monitor and Performance Delay: 60 min
Elevator Sort: Enabled
Degraded Performance Optimization: Disabled
Inconsistency Repair Policy: Disabled
Wait for Cache Room: Disabled
Surface Analysis Inconsistency Notification: Disabled
Post Prompt Timeout: 0 secs
Cache Board Present: True
Cache Status: Not Configured
Accelerator Ratio: 100% Read / 0% Write
Drive Write Cache: Disabled
Read Cache Size: 0 MB
Write Cache Size: 0 MB
Total Cache Size: 144 MB
No-Battery Write Cache: Disabled
Cache Backup Power Source: Batteries
Battery/Capacitor Count: 1
Battery/Capacitor Status: OK
SATA NCQ Supported: True

=> controller slot=4 modify cacheratio=25/75

=> controller slot=4 modify cacheratio=?

Available options are:
0% read / 100% write
25% read / 75% write (default value)
50% read / 50% write
75% read / 25% write
100% read / 0% write (current value)

No changes as you can see. Also nothing changes after reboot.
Can you provide us a solution on this issue?


need logical drives

I asked one of the ACUCLI developers, and got this response:

"I can see that there are no logical drives created on the controller. The cache ratio can only be changed when there is at least one logical drive configured on the controller.
Later versions of ACUCLI will not show the cache ratio information if the controller is not configured."

problem solved

the problem is solved after re-create logical drives