Installing Debian Squeeze on Envy 15

I installed Debian Squeeze on a USB 3.0 equipped Envy 15 laptop with Core i7 processor. This blog details my experience installing and running Debian Squeeze. Keep in mind Debian Squeeze is not released yet and is still changing at a good pace (I tried installing Debian Lenny just for the sake of it and graphic install fails to display anything on the screen. When I pressed ESC, it drops to text mode install but install kernel either panics or hangs. I did not spend much time on it). Hardware specs for the laptop are:

  • Intel(R) Core(TM) i7-720QM Quad Core processor (1.6GHz, 6MB L3 Cache) with Turbo Boost up to 2.8 GHz
  • 4 GB RAM
  • ATI Mobility Radeon HD 5830 Graphics
  • NEC uPD720200 USB 3.0 controller
  • BIOS ver: F.28

I performed a network install starting the installation from an external USB 2.0 DVD-ROM drive.The installer started up fine from DVD but failed to find the DVD drive later. I had originally connected the external drive to one of the USB 3.0 ports. I then connected the drive to the eSATA/USB 2.0 port. After that installer found the DVD drive just fine. This indicates the installer kernel is missing xhci driver. It may be possible to load the xhci driver manually but it was easier to just connect the drive to eSATA/USB 2.0 port.

The second problem I ran into while installing was that touchpad buttons did not work which stalled installation. A USB 1.1/2.0 mouse plugged into one of the two USB 3.0 ports does not work either with installer. Mouse must be plugged into the USB 2.0 port. I had to use an external USB hub so I could plug both DVD drive and mouse into the single USB 2.0 port. Once I got past these two problems, installation went smoothly. During grub installation, other OSs installed on the same hard disk in other partitions were detected bu no entry was made for them in grub menu. This was easily fixed by running update-grub after reboot.

Once Debian was installed and I rebooted the laptop, there were a number of ACPI errors at boot up:

[ 1.405033] ACPI: BIOS _OSI(Linux) query ignored
[ 1.417856] ACPI Error (psargs-0359): [\_PR_.CPU0._PPC] Namespace lookup failure, AE_NOT_FOUND
[ 1.417867] ACPI Error (psparse-0537): Method parse/execution failed [\CPUT] (Node ffff88013fa4d180), AE_NOT_FOUND
[ 1.417919] ACPI Error (psparse-0537): Method parse/execution failed [\PSSC] (Node ffff88013fa4d1a0), AE_NOT_FOUND
[ 1.417969] ACPI Error (psparse-0537): Method parse/execution failed [\_SB_.PCI0.LPCB.EC0_._REG] (Node ffff88013fa42a80), AE_NOT_FOUND
[ 1.418038] Fail in evaluating the _REG object of EC device. Broken bios is suspected.

After boot up, I found that no thermal zones were detected in /proc/acpi/thermal_zone. CPU fan runs continuously, although not at high speed. I did not encounter any overheating issues. Most everything worked fine on the laptop after installation except for the issues noted below:

CPU Frequency Scaling
CPU frequency scaling worked exactly as it should. CPU frequency varied with load in accordance with the selecting scaling policy and the CPU frequency could be locked as well at one of the values
TurboBoost worked on CPU which I verified using the cpustat utility from Len Brown here and here.
Graphics worked fine with Xorg radeon driver and display resolution was set up correctly at 1920x1080. I could not enable compiz with radeon driver. I followed instructions at but compiz fails to start with error message that it detected only software acceleration. /var/log/Xorg.o.log shows radeon driver in use and messages from the radeon driver indicate that direct rendering and acceleration are disabled. A newer version of radeon driver might possibly enable acceleration. I tried installing proprietary ATI driver 8.7.12, but X fails to start. It fails to load with undefined symbol -DPMSEnabledSwitch. I installed 32-bit flash plugin using these instructions and 1080p videos played very smoothly from youtube on iceweasel browser.
HDMI output works at 1080p. There was significant overscan and the picture on TV did not show the top and bottom bars from Gnome desktop.
Text console
Text console was automatically set up at high resolution with no tweaking required
USB 3.0
USB 3.0 driver was loaded automatically and USB 3.0 ports worked well after installation. Write speed to a USB 3.0 Buffalo drive averaged 106 MB/s while read speed avaeraged 130 MB/s
Wifi works after installing firmware-iwlwifi from non-free. Wifi/Bluetooth kill button works fine.
Audio works except the beeps from terminal and initial bong played when gdm starts sound like scratches.. Audio mutes with the Audio mute button but audio mute LED does not turn on and off correctly.
Touchpad works and mouse buttons embedded in touchpad sort of work. Pressing anywhere on the touchpad is recognized as a left mouse click. This is not the same feature as tap to click which I turned off, rather you physically push the touchpad down. Down side is it does not differentiate between right and left click and every click is considered left click, even if you push down on the right bottom corner of touchpad. Touchpad can not be turned off by double tapping the touchpad on/off button
Webcam works with cheese
Bluetooth works. I was able to send/receive files to/from a phone and I was also able to browse filesystem on the phone
Suspend and hibernate
Suspend and hibernate both fail with error logged in dmesg:
[ 1430.193661] pm_op(): usb_dev_suspend+0x0/0xa [usbcore] returns -2
[ 1430.193666] PM: Device usb1 failed to suspend: error -2
[ 1430.193670] PM: Some devices failed to suspend

This looks like a bug in xhci driver.
Special keys
Audio mute, volume up and down keys work. Brightness control keys work and bring up brightness applet display. Calculator key launches a calculator and mail key launches evolution. Web browser key launches a file browser. Print key launches print dialog with right applications. Remaining key with ~ like symbol does not do anything.
ACPI detected the lid button but no thermal zones as noted before.

Update to Debian sid
I updated Squeeze installation to Sid. Changes from Squeeze are noted below:

  • Brightness control applet stopped working
  • Wifi on/off button stopped working
  • Suspend and hibernate work!!
  • HDMI output works at 1080p but colors are wrong and there is significant overscan as before.