Installing Ubuntu Lucid on Envy 15

I recently got a USB 3.0 equipped Envy 15 laptop with Core i7 processor and installed 64-bit version of Ubuntu Lucid on it. My experience installing and running Ubuntu Lucid on Envy 15 was good for the most part. Hardware specs for the laptop are below:

  • Intel(R) Core(TM) i7-720QM Quad Core processor (1.6GHz, 6MB L3 Cache) with Turbo Boost up to 2.8 GHz
  • 4 GB RAM
  • ATI Mobility Radeon HD 5830 Graphics
  • NEC uPD720200 USB 3.0 controller
  • BIOS ver: F.28

I burned a network install image for Ubuntu Lucid 10.04 and installed from a local mirror. The installer started up fine from DVD but fails with error message "Unable to find a medium containing a live file system". I had originally connected the external drive to one of the USB 3.0 ports. I then connected the drive to the eSATA/USB 2.0 port. That made the error message go away. It would seem that the installer can not find the DVD drive and hence can not find the live file system. This indicates xhci driver module is not loaded by the install kernel initially. Once live file system was mounted and graphic installer came up, a USB 1.1/2.0 mouse plugged into USB 3.0 port worked just fine. This means xhci driver does get loaded later. Touchpad buttons worked during installation, so there wasn't a need to connect an external mouse any way. During grub installation, other OSs installed on the same hard disk in other partitions were detected and proper entries were made for them in grub menu.

Once Debian was installed and I rebooted the laptop, there were a number of ACPI errors at boot up:

[ 1.982657] ACPI: BIOS _OSI(Linux) query ignored
[ 1.995080] ACPI Error (psargs-0359): [\_PR_.CPU0._PPC] Namespace lookup failure, AE_NOT_FOUND
[ 1.995349] ACPI Error (psparse-0537): Method parse/execution failed [\CPUT] (Node ffff88013ba4c240), AE_NOT_FOUND
[ 1.995758] ACPI Error (psparse-0537): Method parse/execution failed [\PSSC] (Node ffff88013ba4c260), AE_NOT_FOUND
[ 1.996174] ACPI Error (psparse-0537): Method parse/execution failed [\_SB_.PCI0.LPCB.EC0_._REG] (Node ffff88013ba41b40), AE_NOT_FOUND
[ 1.996604] Fail in evaluating the _REG object of EC device. Broken bios is suspected.

After boot up, I found that no thermal zones were detected in /proc/acpi/thermal_zone. CPU fan runs continuously, although not at high speed. I did not encounter any overheating issues. Most everything worked fine on the laptop after installation except for the issues noted below:

CPU Frequency Scaling
CPU frequency scaling worked exactly as it should. CPU frequency varied with load in accordance with the selecting scaling policy and the CPU frequency could be locked as well at one of the values
TurboBoost worked on CPU which I verified using the cpustat utility from Len Brown here and here.
Ubuntu offered to install proprietary ATI driver which I did. It installed fglrx driver 8.72.11. Graphics worked smoothly at 1920x1080 and I was able to enable desktop effects. Desktop effects from compiz worked smoothly. I installed 32-bit flash plugin from flashplugin-nonfree package and 1080p videos played very smoothly from youtube on firefox browser.
HDMI output works at 1080p. There was no overscan and picture was perfect. Yeah!!
Text console
I could not enable hi-rez text console.I tried the radeon.modeset=1 kernel option but that did not help.
USB 3.0
USB 3.0 driver was loaded automatically and USB 3.0 ports worked well after installation. Write speed to a USB 3.0 Buffalo drive averaged 93 MB/s while read speed averaged 124 MB/s
Wifi works. Wifi/Bluetooth kill button works fine.
Audio works. Audio mutes with the Audio mute button but audio mute LED does not turn on and off correctly.
Touchpad works and mouse buttons embedded in touchpad sort of work. Only button presses in right and left bottom corner are recognized. Touchpad can not be turned off by double tapping the touchpad on/off button
Webcam works with cheese
Bluetooth works. I was able to send/receive files to/from a phone and I was also able to browse filesystem on the phone
Suspend and hibernate
Suspend and hibernate both fail with error logged in dmesg:
[ 1044.861432] pm_op(): usb_dev_suspend+0x0/0x20 returns -2
[ 1044.861434] PM: Device usb2 failed to suspend: error -2
[ 1044.861435] PM: Some devices failed to suspend

This looks like a bug in xhci driver.
Special keys
Audio mute, volume up and down keys work. Brightness control keys work but there is no on-screen display of current brightness level.. Calculator key launches a calculator and mail key launches evolution. Web browser key launches a file browser. Print key launches print dialog with right applications. Remaining key with ~ like symbol does not do anything.
ACPI detected the lid button but no thermal zones as noted before. Laptop failed to power down with F.24 BIOS but that problem went away with upgrade to F.28.

Notes from Ubuntu Karmic
I installed Ubuntu Karmic (64-bit) as well on this laptop. Some differences in operation are noted below:

  • Karmic kernel detected one thermal zone!!
  • HDMI output did not work
  • Sound did not work